<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.6.5.4" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says | kare11.com</title>
    <script>window.tegna=window.tegna||{},window.tegna.getCookie=e=>{const n="; "+document.cookie,t=n.split(`; ${e}=`);return 2===t.length?t.pop().split(";").shift():null},window.tegna.usprivacy=window.tegna.getCookie("usprivacy"),function(){window.performance.mark("tegna_server_response");var n=new URLSearchParams(window.location.search).get("otConsentString");if(n){document.cookie="OptanonAlertBoxClosed="+(new Date).toISOString();let e=new Date;e.setYear(e.getFullYear()+1),e=e.toISOString();var t=(new Date).toString().replace(/\ /g,"+").replace(/:/g,"%3A");document.cookie=`OptanonConsent=datestamp=${t}&version=6.0.0&interactionCount=0&isIABGlobal=false&landingPath=NotLandingPage&groups=${encodeURIComponent(n)}&hosts=&legInt=; expires=`+e}}(),window.tegna.supportsJavascript="noModule"in document.createElement("script"),window.tegna.supportsJavascript?(document.documentElement.classList.remove("root_js_disabled"),window.tegna.performance={received:{time:window.performance.now()}},window.tegna.ie=!!window.MSInputMethodContext&&!!document.documentMode):document.documentElement.classList.add("root_ie_true");
//# sourceMappingURL=immediate.js.map</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #045ea8;
    --theme-secondary: #045ea8;
}</style>

<link rel="preload" href="/modules.min_6.5.4.css" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };window.performance.mark('tegna_styled');" />
<noscript><link rel="stylesheet" href="/modules.min_6.5.4.css"></noscript>

<link rel="preload" href="/common.min_6.5.4.js" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
    <link rel="icon" href="/assets/favicons/KARE.png?ver=2.6.5.4" />
    <link rel="canonical" href="https://www.etonline.com/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says-187228" />
            <meta name="theme-color" content="#045ea8" />
            <link rel="amphtml" href="https://www.kare11.com/amp/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92" />
        <meta itemprop="datePublished" content="1:27 AM CDT July 13, 2022" />
        <meta itemprop="dateModified" content="1:27 AM CDT July 13, 2022" />
        <meta itemprop="url" content="https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92" />
        <meta itemprop="magnet:custom" name="category" content="entertainment" />
        <meta property="og:url" content="https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92">
        <meta property="og:title" content="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says">
        <meta property="og:description" content="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="1:27 AM CDT July 13, 2022" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta property="article:section" content="kare11,entertainment,entertainment-tonight" />
        <meta name="twitter:title" content="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says">
        <meta name="twitter:image:src" content="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1140x641.jpg">
        <meta name="twitter:image" content="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1140x641.jpg">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="KARE11">
        <meta name="twitter:description" content="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says">
        <meta name="twitter:domain" content="www.kare11.com/">


            <meta name="viewport" content="width=1170" />
            <meta name="site" content="kare11.com" />
            <meta name="description" content="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says" />
            <meta property="fb:app_id" content="1668015679912083" />
            <meta property="og:site_name" content="kare11.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="1:27 AM CDT July 13, 2022" />
    <script>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</script>
        <!-- OneTrust Cookies Consent Notice start -->
        <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="1e31fd44-712c-4f0a-bebb-c1d649872149"></script>
        <script type="text/javascript">function OptanonWrapper() { }</script>
        <!-- OneTrust Cookies Consent Notice end -->
        <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004,C0002" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>
<!-- utag_data -->
<script id="utag_data_script" data-visit-event-name="pageView" data-current-site-id="89" data-watson-keywords="Pete Davidson Are,Kim Kardashian,9-year-old daughter North,Pete Davidson,6-year-old son Saint" data-page-type="article" data-gpt-network-code="32805352/mn-minneapolis-KARE-B3323_DesktopTablet" data-section="entertainment" data-subsection="entertainment-tonight" data-topic="" data-subtopic="" data-content-type="article" data-category="entertainment" data-market="Minneapolis, MN" data-subcategory="entertainment-tonight" data-keywords="KARE, Minneapolis, St. Paul, Minnesota, news, local news, breaking news, traffic, weather, sports, events" data-document-title="Minneapolis St. Paul News, Weather, Traffic, Sports | Minneapolis, Minnesota | kare11.com" data-ga-property-id="UA-72620100-1" data-division="broadcast" data-site-type="desktop" data-page-url="https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92" data-canonical-url="https://www.etonline.com/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says-187228" data-asset-id="855465aa-e3de-4001-bcfc-52655c3fdc92" data-article-keywords="entertainment,celebrity news,entertainment-tonight" data-content-title="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says" data-content-categories="entertainment,entertainment-tonight" data-content-score="" data-tracking-tags="" data-t1-publisher="" data-call-letters="KARE" data-article-byline="Zach Seemayer&#x200D;" data-topics-included="false" data-video-included="false" data-video-autoplay="false" data-video-title="" data-video-name="" data-video-length="0" data-video-related-play="false" data-item-number="1" data-original-headline="Kim Kardashian and Pete Davidson Are &amp;#039;So In Love,&amp;#039; He&amp;#039;s &amp;#039;Amazing With Her Children,&amp;#039; Source Says" data-cct-story="false" data-platform="desktop" data-full-environment="KARE" data-index-wrapper-url="//js-sec.indexww.com/ht/p/184603-126828921747566.js" data-a9-publisher-id="3276" data-a9-timeout="1000" data-oneplusx-client-id="tegna" data-oneplusx-debug="false" data-pubmatic-desktop-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3917/pwt.js" data-pubmatic-mobile-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3918/pwt.js">!function(){var e;window.tegna.supportsJavascript&&(e=document.getElementById("utag_data_script").dataset,window.tegna.initialTracking={visit_event_name:e.visitEventName,current_site_id:e.currentSiteId,watson_keywords:e.watsonKeywords,template_type:"",page_type:e.pageType,division:e.division,site_type:e.siteType,page_url:e.pageUrl,gpt_network_code:e.gptNetworkCode,section:e.section,subsection:e.subsection,topic:e.topic,subtopic:e.subtopic,content_type:e.contentType,category:e.category,market:e.market,subcategory:e.subcategory,keywords:e.keywords,document_title:e.documentTitle,ga_property_id:e.gaPropertyId,canonical_url:e.canonicalUrl,video_included:e.videoIncluded,video_name:e.videoName,video_length:e.videoLength,video_related_play:e.videoRelatedPlay,article_date:e.articleDate,asset_id:e.assetId,article_keywords:e.articleKeywords,content_title:e.contentTitle,original_headline:e.originalHeadline,content_categories:e.contentCategories,tracking_tags:e.trackingTags,t1_publisher:e.t1Publisher,article_byline:e.articleByline,topics_included:e.topicsIncluded,call_letters:e.callLetters,item_number:e.itemNumber,content_score:e.contentScore,cct_story:e.cctStory,platform:e.platform,full_environment:e.fullEnvironment,index_wrapper_url:e.indexWrapperUrl,a9_publisher_id:e.a9PublisherId,a9_timeout:e.a9Timeout,oneplusx_client_id:e.oneplusxClientId,oneplusx_debug:"true"===e.oneplusxDebug.toLowerCase(),pubmatic_desktop_url:e.pubmaticDesktopUrl,pubmatic_mobile_url:e.pubmaticMobileUrl},window.utag_data=JSON.parse(JSON.stringify(window.tegna.initialTracking)))}();
//# sourceMappingURL=utag-data.js.map</script>
        <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">
    var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
            }</script>
    <style>
        .root_ie_true template {
            display: none;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-header {
            position: relative;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-logo {
            background-image: url('/assets/shared-images/logos/kare.png') !important;
        }
    </style>
    <script type="text/javascript" data-taboola-type="article">window._taboola = window._taboola || [];
        let obj = {};
        obj[document.currentScript.dataset.taboolaType] = 'auto';
        _taboola.push(obj);</script>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <input name="__RequestVerificationToken" type="hidden" value="CfDJ8AYvw3C2z1tNjpyMc4j8Mzkn50rV0lYkVfnal97NbYPCDnAfl19oMX57w-wQSdlNcBg2h75sRUZGy3SdfWLCPCnV0nlfX-MpuQ-RkozoDlLJkjpXp22NjqKvUX80KSaVSkgTqMqGSqsaNbneoWuTNxE" />
    <script>if(window.tegna.supportsJavascript){window.tegna.addScript=e=>{var t=document.createElement("script");t.src=e,document.head.appendChild(t)},window.tegna.log=function(e,t,i,n){var o=(o=20-e.length)<0?0:o,a=(a=30-t.length)<0?0:a,r="log",n=("error"in console&&3===n?r="error":"warn"in console&&2===n?r="warn":"info"in console&&(r="info"),"["+e+"] "+" ".repeat(o)+t+" ".repeat(a));"production"!==document.getElementsByClassName("page")[0].dataset.environment.toLowerCase()&&(i?console[r](n,i):console[r](n))},window.tegna.loadModule=function(e,i){var n=e.parentNode,o=n.querySelectorAll(".grid__template")[0],a=("undefined"!=typeof templatePolyfill&&templatePolyfill(n),document.importNode(o.content,!0)),t="IntersectionObserver"in window&&"IntersectionObserverEntry"in window;e.remove(),t?new window.IntersectionObserver(function(e,t){e.forEach(function(e){if(e.isIntersecting){o.remove(),n.append(a),n.closest(".grid__module").classList.add("grid__module_loaded_true"),n.closest(".grid__module").classList.remove("grid__module_loaded_false"),t.unobserve(n),"undefined"!=typeof require&&require([i]);let e={el:n};"$"in window&&(e.$el=$(n)),window.dispatchEvent(new CustomEvent("tegnaBroadcast",{detail:{source:"grid",action:"addedSection",data:e}}))}})}).observe(n):(o.remove(),n.append(a))};class a extends HTMLElement{get os(){return this.getAttribute("os")}set os(e){this.setAttribute("os",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}connectedCallback(){var e=navigator.userAgent||navigator.vendor||window.opera;let t="unknown";/android/i.test(e)&&(t="android"),(t=/iPad|iPhone|iPod/.test(e)&&!window.MSStream?"ios":t)===this.os.toLowerCase()?this.active=!0:this.active=!1}}window.customElements.define("tegna-sniff",a);class b extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}}window.customElements.define("tegna-variant",b);class c extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}constructor(){super()}connectedCallback(){window.setTimeout(()=>{let t=[...this.children],r=t[0].uuid;var e=window.localStorage.getItem(this.uuid);null!==e?(r=e,window.tegna.log("_abtest","showingStoredVariant",{test:this.uuid,variant:e})):(r=t[e=t.length,Math.floor(Math.random()*Math.floor(e))].uuid,window.localStorage.setItem(this.uuid,r),window.localStorage.setItem(this.uuid+"_tegna_expire",Date.now()+108e5),window.tegna.log("_abtest","showingNewVariant",{test:this.uuid,variant:r}));const i=async(e,t,i)=>{var n=document.querySelector(".page").dataset.uxTrackingUrl,o=document.querySelector('[name="__RequestVerificationToken"]').value;const a=await fetch(n,{method:"POST",headers:{"Content-Type":"application/json",pragma:"no-cache","cache-control":"no-cache","XSRF-TOKEN":o},body:JSON.stringify({testId:this.uuid,siteId:document.querySelector(".page").dataset.siteId,variantId:r,click:e?1:0,impression:t?1:0})});a.text().then(e=>{i(e)})};for(var n=0;n<t.length;n++)if(t[n].uuid===r){t[n].active=!0,[...t[n].querySelectorAll("a:not([data-ab-click-mode=ignore])")].forEach((t,e)=>{t.addEventListener("click",e=>{e.preventDefault(),e.stopPropagation(),i(!0,!1,()=>{window.location=t.getAttribute("href")}),window.setTimeout(()=>{window.location=t.getAttribute("href")},500)})});let e=new IntersectionObserver((e,t)=>{e.forEach(e=>{e.isIntersecting?(window.tegna.log("_abtest","attemptingImpression",{el:this,test:this.uuid,variant:r}),i(!1,!0,()=>{window.tegna.log("_abtest","impression",{el:this,test:this.uuid,variant:r})}),t.unobserve(e.target)):window.tegna.log("_abtest","notIntersecting")})});e.observe(this)}else t[n].active=!1})}}window.customElements.define("tegna-ab",c)}
//# sourceMappingURL=above-page-scripts.js.map</script>
    <div data-module="page" data-state="ready" class="page"
         data-embed="false"
         data-platform="desktop"
         data-page-type="article"
         data-ux-tracking-url="https://abtesting.tegnadigital.com/api/SendUxAbTestingData?code=gHyo3LvlLypaYLJwJNPDrp6xmP643xUknqluStUeQNYiz6nNkSGOKw=="
         data-environment="Production"
         data-is-monitor="false"
         data-is-preview="false"
         data-site-id="89"
         data-primarydomain="kare11.com"
         data-environment-base-url="https://www.kare11.com/"
         data-call-letters="KARE"
         data-full-environment="KARE"
         data-twitter-id="KARE11"
         data-fban="1668015679912083"
         data-refresh="420"
         data-dfpid="32805352"
         data-comscoreid="6035223"
         data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
         data-targeting-video_included="false"
         data-targeting-ttid=""
         data-targeting-pgtype="article"
         data-targeting-topic_section=""
         data-targeting-url="https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92"
         data-is-video="false"
         data-is-longform="false"
         data-gptid="mn-minneapolis-KARE-B3323_DesktopTablet"
         data-tealium-url="//tags.tiqcdn.com/utag/tegna/kare-redesign-desktop/prod/utag"
         data-taboola-url="https://www.etonline.com/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says-187228"
         data-elvs-id="8"
         data-assets-base-url="https://media.kare11.com"
         data-elvs-stream-url="https://livevideo.tegnadigital.com/kare/v1/master/f9c1bf9ffd6ac86b6173a7c169ff6e3f4efbd693/KARE/elvs/live.m3u8"
         data-is-elvs-disabled="false"
         data-hls-js-url="https://amp.akamaized.net/players/9.1.8&#x2B;premier/akamai/amp/core/libs/hls.min"
         data-tealium-id-comscore="1"data-tealium-id-googleanalytics="536"data-tealium-id-oneplusx="548"data-tealium-id-simplifi="516"data-tealium-id-taboola="515"         >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
    <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_universal/entertainment/entertainment-tonight"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-position="article_universal"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
            <div class="page__header">
<header data-module="header" class="header"
        data-alerts="false"
        data-facebook-app-id="1668015679912083"
        data-twitter-id="KARE11">
    <a class="header__skip" href="#main" tabindex="1">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container" role="button" tabindex="0">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="KARE 11 Home" src="/assets/shared-images/logos/kare.png" loading="eager" width="103" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <div class="header__tooltip-overlay"></div>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/news" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="News">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Local">
                                                                    <span class="header__subnav-label">Local</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/community" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Community">
                                                                    <span class="header__subnav-label">Community</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/sports" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sports">
                                                                    <span class="header__subnav-label">Sports</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Entertainment">
                                                                    <span class="header__subnav-label">Entertainment</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/extras" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Extras">
                                                                    <span class="header__subnav-label">Extras</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/health" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Health">
                                                                    <span class="header__subnav-label">Health</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nation World">
                                                                    <span class="header__subnav-label">Nation World</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/money" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Money">
                                                                    <span class="header__subnav-label">Money</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Politics">
                                                                    <span class="header__subnav-label">Politics</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/features" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Features">
                                                                    <span class="header__subnav-label">Features</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/shows" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Shows">
                                                                    <span class="header__subnav-label">Shows</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/coronavirus-covid-19" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Coronavirus">
                                                                    <span class="header__subnav-label">Coronavirus</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.kare11.com/article/news/crime/jamal-smith-murder-trial-judge-prohibits-boughton-family-supporters-from-wearing-yellow/89-da114af7-ca93-44f1-9583-79a5c04a9c7e" aria-label="Read Jamal Smith murder trial: Judge prohibits Boughton family supporters from wearing yellow" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Jamal Smith murder trial: Judge prohibits Boughton family supporters from wearing yellow">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Jamal Smith murder trial: Judge prohibits Boughton family supporters from wearing yellow" width="" height="" src="https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Jamal Smith murder trial: Judge prohibits Boughton family supporters from wearing yellow" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_360x203.jpg" data-srcset="https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_16x9.jpg 16w, https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_140x79.jpg 140w, https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_360x203.jpg 360w, https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_540x304.jpg 540w, https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_750x422.jpg 750w, https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_1140x641.jpg 1140w, https://media.kare11.com/assets/KARE/images/bca15d93-a878-4729-aaa7-13a017b0374e/bca15d93-a878-4729-aaa7-13a017b0374e_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.kare11.com/article/news/crime/jamal-smith-murder-trial-judge-prohibits-boughton-family-supporters-from-wearing-yellow/89-da114af7-ca93-44f1-9583-79a5c04a9c7e" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Jamal Smith murder trial: Judge prohibits Boughton family supporters from wearing yellow">Jamal Smith murder trial: Judge prohibits Boughton family supporters from wearing yellow</a></h4>
                    </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.kare11.com/article/sports/nhl/wild/wild-send-cam-talbot-to-ottawa/89-dc6fc949-6e40-4046-91b7-992feac9771a" aria-label="Read Wild send goaltender Cam Talbot to Ottawa for new backup Filip Gustavsson" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Wild send goaltender Cam Talbot to Ottawa for new backup Filip Gustavsson">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Wild send goaltender Cam Talbot to Ottawa for new backup Filip Gustavsson" width="" height="" src="https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Wild send goaltender Cam Talbot to Ottawa for new backup Filip Gustavsson" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_360x203.jpg" data-srcset="https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_16x9.jpg 16w, https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_140x79.jpg 140w, https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_360x203.jpg 360w, https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_540x304.jpg 540w, https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_750x422.jpg 750w, https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_1140x641.jpg 1140w, https://media.kare11.com/assets/KARE/images/ae658a4b-d902-42fb-a8e9-04f6705677ec/ae658a4b-d902-42fb-a8e9-04f6705677ec_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.kare11.com/article/sports/nhl/wild/wild-send-cam-talbot-to-ottawa/89-dc6fc949-6e40-4046-91b7-992feac9771a" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Wild send goaltender Cam Talbot to Ottawa for new backup Filip Gustavsson">Wild send goaltender Cam Talbot to Ottawa for new backup Filip Gustavsson</a></h4>
                    </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/weather/" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/article/weather/latest-minnesota-weather/89-d44129df-c1cb-4874-9a11-9e5ae525daeb" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Forecast">
                                                                    <span class="header__subnav-label">Forecast</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Radar">
                                                                    <span class="header__subnav-label">Radar</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/closings" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Closings &amp; Delays">
                                                                    <span class="header__subnav-label">Closings &amp; Delays</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Traffic">
                                                                    <span class="header__subnav-label">Traffic</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.kare11.com/article/weather/forecast/latest-minnesota-weather/89-d44129df-c1cb-4874-9a11-9e5ae525daeb" aria-label="Read WEATHER: Splendid weather day" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; WEATHER: Splendid weather day">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="WEATHER: Splendid weather day" width="" height="" src="https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="WEATHER: Splendid weather day" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_360x203.jpg" data-srcset="https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_16x9.jpg 16w, https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_140x79.jpg 140w, https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_360x203.jpg 360w, https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_540x304.jpg 540w, https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_750x422.jpg 750w, https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_1140x641.jpg 1140w, https://media.kare11.com/assets/KARE/images/6369af57-da1b-4a56-9036-5a84201f156a/6369af57-da1b-4a56-9036-5a84201f156a_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.kare11.com/article/weather/forecast/latest-minnesota-weather/89-d44129df-c1cb-4874-9a11-9e5ae525daeb" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; WEATHER: Splendid weather day">WEATHER: Splendid weather day</a></h4>
                    </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.kare11.com/video/weather/the-late-morning-forecast-for-wednesday-july-13/89-0e37892a-0fc8-484b-9e42-a1db52583c4a" aria-label="Read The late morning forecast for Wednesday, July 13" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; The late morning forecast for Wednesday, July 13">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="The late morning forecast for Wednesday, July 13" width="" height="" src="https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="The late morning forecast for Wednesday, July 13" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_360x203.jpg" data-srcset="https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_16x9.jpg 16w, https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_140x79.jpg 140w, https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_360x203.jpg 360w, https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_540x304.jpg 540w, https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_750x422.jpg 750w, https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_1140x641.jpg 1140w, https://media.kare11.com/assets/KARE/images/86ffa8de-3b43-45c2-99fd-bac87aa21e35/86ffa8de-3b43-45c2-99fd-bac87aa21e35_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.kare11.com/video/weather/the-late-morning-forecast-for-wednesday-july-13/89-0e37892a-0fc8-484b-9e42-a1db52583c4a" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; The late morning forecast for Wednesday, July 13">The late morning forecast for Wednesday, July 13</a></h4>
                    </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/near-me" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Near Me">
                                        <span class="header__nav-label">Near Me</span>
                            </a>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/verify" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                        <span class="header__nav-label">VERIFY</span>
                            </a>
                        </li>
                        <li>
                            <div class="header__mini-live-video">
<div data-module="watch-live" class="watch-live watch-live_active_true" data-watch-enabled="true">
    <a class="watch-live__cta" href="/watch">
        <span class="watch-live__label">Watch Live</span>
    </a>
    <div class="watch-live__mini-live-video watch-live__mini-live-video_active_true">
        <a class="watch-live__video-link" href="/watch">
    <div data-module="mini-live-video" class="mini-live-video mini-live-video_state_playing" data-is-watch="false">    
        <div class="mini-live-video__player"></div>
    </div>        </a>
    </div>
</div>                            </div>
                        </li>
                    <li class="header__nav-search header__nav-search_type_search">
                        <a class="header__nav-link header__nav-link_type_search" href="/search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </a>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search kare11.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                            <button class="header__close-button" aria-label="close"></button>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
    <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/masthead_sponsor/entertainment/entertainment-tonight"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-position="masthead_sponsor"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92" aria-label="Visit the weather page">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_false">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_false">Minneapolis, MN&nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_false">
                                <div class="header__weather-temp header__weather-temp_alerts_false">63&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_false">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-69_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-69_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-69_8x8.png 8w, /assets/shared-images/weather-icons/wx-69_16x16.png 16w, /assets/shared-images/weather-icons/wx-69_32x32.png 32w, /assets/shared-images/weather-icons/wx-69_64x64.png 64w, /assets/shared-images/weather-icons/wx-69_128x128.png 128w, /assets/shared-images/weather-icons/wx-69_210x210.png 210w" sizes="26px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-69_32x32.png" srcset="/assets/shared-images/weather-icons/wx-69_8x8.png 8w, /assets/shared-images/weather-icons/wx-69_16x16.png 16w, /assets/shared-images/weather-icons/wx-69_32x32.png 32w, /assets/shared-images/weather-icons/wx-69_64x64.png 64w, /assets/shared-images/weather-icons/wx-69_128x128.png 128w, /assets/shared-images/weather-icons/wx-69_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_false">Minneapolis, MN&nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_false" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92">Weather</a>
                    <a class="header__alert header__alert_type_closings header__alert_visible_false" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <button disabled class="header__featured-arrow header__featured-arrow_direction_previous"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></button>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/advertise">Advertise With Us</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/article/about-us/kare-11-news-free-and-on-demand-on-roku-and-fire-tv/89-5efa72e4-8993-4449-8eb4-dea4a1d22873">KARE 11&#x2B;</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/lockedon">Locked On Sports Minnesota</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/article/news/local/kare-11-news-featured-links/89-44022f85-e470-46e3-a182-8a540ce42946">Links</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/kare-investigates">KARE 11 Investigates</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/breakingthenews">Breaking the News</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/sunrise">Sunrise</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/landof10000stories">Land of 10,000 Stories</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/vote">Voter&#x27;s Toolkit</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/verify">VERIFY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/antenna">Antenna Rescan</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/vaccine">Vax Facts</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/grow-with-kare">Grow with KARE</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/weatherminds">Weatherminds</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/money">Money</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/behindthebusiness">Behind the Business</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/healthfair11">Healthfair 11</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/recipes">Recipes</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/communities-that-kare">Communities that KARE</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/contests">Contests</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/tv-listings">TV Listings</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/meet-the-team">Meet the KARE 11 team</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.kare11.com/closings">Closings &amp; Delays</a>
                        </li>
                </ul>
            </div>
            <button disabled class="header__featured-arrow header__featured-arrow_direction_next"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></button>
    </div>
</header>            </div>
            <div class="page__dock">
                    <div class="page__breaking-news-alerts">
    <div data-module="breaking-news-alerts" class="breaking-news-alerts breaking-news-alerts_visible_false">
        <div class="breaking-news-alerts__wrap">
            <div class="breaking-news-alerts__close"></div>
            <div class="breaking-news-alerts__label">Breaking News</div>
            <ul class="breaking-news-alerts__headline-wrap">
                <template class="breaking-news-alerts__template">
                    <li class="breaking-news-alerts__item">
                        <a class="breaking-news-alerts__link" href="#" data-tracking="breaking-news-alerts/linkClicked">
                            <span class="breaking-news-alerts__headline"></span>
                            <span class="breaking-news-alerts__read-more">Read More &raquo;</span>
                        </a>
                    </li>
                </template>
            </ul>
            <a class="breaking-news-alerts__more" href="/breaking-news" data-tracking="breaking-news-alerts/moreClicked">More (<span class="breaking-news-alerts__count"></span>) &raquo;</a>
        </div>
    </div>
                    </div>
            </div>
        <main class="page__main" id="main">
            <div class="page__grid">
                


    <div data-module="grid" class="grid grid_version_2-1">
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full">
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="855465aa-e3de-4001-bcfc-52655c3fdc92"
         data-title="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says"
         data-seo-title="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says"
         data-abstract="Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says"
         data-section="entertainment"
         data-subsection="entertainment-tonight"
         data-topic=""
         data-subtopic=""
         data-url="https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92"
         data-pathname="www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92"
         data-gpt-network-code="32805352"
         data-categories="entertainment,entertainment-tonight"
         data-author="Zach Seemayer&#x200D;"
         data-keywords="entertainment,celebrity news,entertainment-tonight"
         data-has-video="false"
         data-watson-keywords="Pete Davidson Are,Kim Kardashian,9-year-old daughter North,Pete Davidson,6-year-old son Saint"
         data-t1-publisher=""
         data-is-cct="false"
         data-original-headline="Kim Kardashian and Pete Davidson Are &amp;#039;So In Love,&amp;#039; He&amp;#039;s &amp;#039;Amazing With Her Children,&amp;#039; Source Says"
         data-content-score=""
         data-tracking-tags="">
            <a class="article__category" href="/section/entertainment-tonight" data-tracking-category="article" data-tracking-action="click" data-tracking-label="article; topic; Entertainment Tonight">Entertainment Tonight</a>
            <h1 class="article__headline">Kim Kardashian and Pete Davidson Are &#x27;So In Love,&#x27; He&#x27;s &#x27;Amazing With Her Children,&#x27; Source Says</h1>
            <div class="article__summary">Kim Kardashian and Pete Davidson Are 'So In Love,' He's 'Amazing With Her Children,' Source Says</div>
        <div class="article__lead-asset">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="750" height="422" src="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="750" height="422" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_750x422.jpg" data-srcset="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_16x9.jpg 16w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_140x79.jpg 140w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_360x203.jpg 360w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_540x304.jpg 540w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_750x422.jpg 750w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1140x641.jpg 1140w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1920x1080.jpg 1920w" sizes="750px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="750" height="422" src="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_750x422.jpg" srcset="https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_16x9.jpg 16w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_140x79.jpg 140w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_360x203.jpg 360w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_540x304.jpg 540w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_750x422.jpg 750w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1140x641.jpg 1140w, https://media.kare11.com/assets/ETONLINE/images/af8f1a48-eba3-493e-864b-d5412fcb2c56/af8f1a48-eba3-493e-864b-d5412fcb2c56_1920x1080.jpg 1920w" sizes="750px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>        </div>
        <aside class="article__meta">
                <div class="article__author">
                    <span class="article__meta-label">Author:</span> Zach Seemayer&#x200D;
                </div>
                <div class="article__published">
                    <span class="article__meta-label">Published:</span> 1:27 AM CDT July 13, 2022
                </div>
                <div class="article__updated">
                    <span class="article__meta-label">Updated:</span> 1:27 AM CDT July 13, 2022
                </div>
            <div class="article__sharing">
    <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=1668015679912083&display=popup&href=https%3A%2F%2Fwww.kare11.com%2Farticle%2Fentertainment%2Fentertainment-tonight%2Fkim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says%2F603-855465aa-e3de-4001-bcfc-52655c3fdc92&redirect_uri=https%3A%2F%2Fwww.kare11.com%2Farticle%2Fentertainment%2Fentertainment-tonight%2Fkim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says%2F603-855465aa-e3de-4001-bcfc-52655c3fdc92" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=Kim%20Kardashian%20and%20Pete%20Davidson%20Are%20%27So%20In%20Love%2C%27%20He%27s%20%27Amazing%20With%20Her%20Children%2C%27%20Source%20Says&url=https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92&via=KARE11" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>            </div>
        </aside>
    <div class="article__body">
                                <div class="article__section article__section_type_embed">
                                        <article role="article">

  
      <h2>
      <a href="/media/videos/kim-kardashian-consulted-therapists-before-introducing-kids-to-pete-davidson-186083" rel="bookmark">
  

      <h2 class="field field-title field-title--video-iframe field-type-string field-type-string--video-iframe heading">Kim Kardashian Consulted Therapists Before Introducing Kids to Pete Davidson</h2>

</a>
    </h2>
    

  
  <div>
    <div class="field field-video-mpx-id field-video-mpx-id--video-iframe field-type-string field-type-string--video-iframe"><div style="position: relative; max-width: 640px;"><div style="padding-top: 56.25%;"><iframe src="https://embed.etonline.com/video-embed/video_iframe_player/2689d462-3549-4987-a608-92d680841080" data-label="embedded-player" allowfullscreen frameborder="0"></iframe></div></div></div>
  </div>

</article>


                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a href="https://www.etonline.com/people/pete-davidson" rel="" target="_blank">Pete Davidson</a> is bringing light into <a href="https://www.etonline.com/people/kim-kardashian" rel="" target="_blank">Kim Kardashian's</a> life. The pair have been dating for several months, and it seems that things are only getting more fun and more serious.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>A source tells ET, "Pete and Kim are so in love. Kim is light and happy with Pete and it shows in so many ways, including being a mom, with her work, in her friendships, and more."</p>                    </div>
                        <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_mid1/entertainment/entertainment-tonight"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-position="article_mid1"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text utility__text">
<p>"Pete has made a real effort to immerse himself into Kim's world and with her family and kids," the source adds. "He is so amazing with her children and she loves seeing him be silly with them and take an interest in their lives."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Kim <a href="https://www.etonline.com/kim-kardashian-and-north-west-wear-matching-nose-rings-while-attending-paris-fashion-show-186871" rel="" target="_blank">is the mother of four</a> -- 9-year-old daughter North, 6-year-old son Saint, 4-year-old daughter Chicago and 3-year-old daughter Psalm -- whom she shares with her ex, Kanye "Ye" West.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The source says that Pete is "fully committed" to Kim and "loves being with her no matter what they're doing."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>"They are very supportive of each other and have so much fun together, but also have a deep connection," the source adds. "They are living in the moment, but also see a future together."4</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The 28-year-old former <em>Saturday Night Live</em> star told Kevin Hart in a recently released sneak peek of <em>Hart to Heart </em>season 2 on Peacock that, despite not having a great childhood,<a href="https://www.etonline.com/pete-davidson-says-its-his-dream-to-have-a-kid-my-favorite-thing-ever-187199" rel="" target="_blank"> he can't wait to be a father one day</a>. Davidson gushed about the future life-changing milestone, calling it his ultimate dream.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>"Definitely a family guy," he said. "My favorite thing ever, which I have yet to achieve, I wanna have a kid. That's like my dream. It's like, super corny, [but] it would be so fun. Dress up the little dude. It's just like, I'm so excited for that chapter. That's kind of what I'm just preparing for now, is just trying to be as good as a dude, develop and get better so when that happens it's just easier."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Back in June, a source told ET that Davidson and Kardashian's connection was only getting stronger after <a href="https://www.etonline.com/inside-pete-davidsons-bond-with-kim-kardashians-kids-185414" rel="" target="_blank">he bonded with her kids</a>. The source said that "the kids and Pete get along very well and Kim seeing him be so great with them only made her fall in love with Pete more."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Check out the video below to hear more.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>RELATED CONTENT:</strong></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/pete-davidson-appears-to-have-a-jasmine-and-aladdin-tattoo-to-honor-his-and-kim-kardashians-snl">        Pete Davidson Appears to Have a 'Jasmine and Aladdin' Tattoo    </a></p>                    </div>
                                <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid2 ad_background_true"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_mid2/entertainment/entertainment-tonight"
         data-sizes="[[300,250],[1,1]]"
         data-delay="8"
         data-position="article_mid2"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey="[&#xD;&#xA;  &quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;&#xD;&#xA;]"
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/media/videos/kim-kardashian-responds-to-pete-davidson-foot-fetish-question-from-sister-khloe-187160">        Kim Kardashian Responds to Pete Davidson Foot Fetish Question From Sister Khloé     </a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/the-kardashians-kim-wants-to-shower-with-new-boyfriend-pete-davidson-in-teaser-for-season-2-187096">        Kim Wants to Shower With Pete Davidson in New 'Kardashians' Teaser    </a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/how-colin-jost-feels-about-pete-davidson-leaving-saturday-night-live-exclusive-187014">        How Colin Jost Feels About Pete Davidson Leaving 'Saturday Night Live'    </a></p>                    </div>
    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "Kim Kardashian and Pete Davidson Are 'So In Love,' He's 'Amazing With Her Children,' Source Says",
  "datePublished": "1:27 AM CDT July 13, 2022",
  "dateModified": "1:27 AM CDT July 13, 2022",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.kare11.com/article/entertainment/entertainment-tonight/kim-kardashian-and-pete-davidson-are-so-in-love-hes-amazing-with-her-children-source-says/603-855465aa-e3de-4001-bcfc-52655c3fdc92"
  },
  "author": {
    "@type": "Person",
    "name": "Zach Seemayer‍"
  },
  "publisher": {
    "@type": "Organization",
    "name": "KARE",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.kare11.com/assets/shared-images/amp-logos/kare.png",
      "width": 340,
      "height": 60
    }
  },
  "image": null
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true grid__module_padding_none">
                                    <div class="grid__module-sizer grid__module-sizer_name_public-good" data-module-sizer="public-good" data-count="1">


<div data-module="public-good" class="public-good public-good_populated_false">
        <p class="public-good__disclaimer public-good__disclaimer_visible_false">Paid Advertisement</p>
    <div class="public-good__slot"></div>
</div>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full">
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="https://www.kare11.com/::contentUrl::"
         data-id="taboola-below-article-thumbnails-2nd-::articleNumber::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
    <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_atf/entertainment/entertainment-tonight"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-position="article_atf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_atf/entertainment/entertainment-tonight&amp;sz=300x250&amp;c=1" width="300" height="250" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full">
                                    <div class="grid__module-sizer grid__module-sizer_name_related-videos" data-module-sizer="related-videos" data-count="1">
    <div data-module="related-videos" class="related-videos">
        <div class="related-videos__player">
        <div data-module="video" class="video video_docked_false"
             data-stream="https://video.tegna-media.com/assets/KARE/videos/f951b892-f04a-4b0e-973e-03b2449819b9/f951b892-f04a-4b0e-973e-03b2449819b9.m3u8"
             data-float="false"
             data-thumbnail="https://media.kare11.com/assets/KARE/images/cfac5721-b746-403f-9275-6dbc5814287c/cfac5721-b746-403f-9275-6dbc5814287c_1920x1080.jpg"
             data-title="&#x27;Wonder of the Wolves&#x27; offers in-depth look at northern Minnesota pack"
             data-description="Disney is behind a new series that offers an unusually close look at the evasive beast known as the wolf, and the subjects are from northern Minnesota."
             data-site="89"
             data-id="f951b892-f04a-4b0e-973e-03b2449819b9"
             data-mute="true"
             data-autoplay="true"
             data-link="https://www.kare11.com/video/news/local/kare11-sunrise/wonder-of-the-wolves-offers-in-depth-look-at-northern-minnesota-pack/89-f951b892-f04a-4b0e-973e-03b2449819b9"
             data-origin="video"
             data-section="news"
             data-subsection="local"
             data-subcategory="local"
             data-topic="kare11-sunrise"
             data-subtopic=""
             data-categories="kare11-sunrise,outdoors,life,news,local"
             data-captions=""
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="On Demand"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration=""
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="true"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="1668015679912083"
             data-sharing-twitter-title="&#x27;Wonder of the Wolves&#x27; offers in-depth look at northern Minnesota pack"
             data-sharing-twitter-username="KARE11"
             data-a9-pubid="3276"
             data-related-autoplay-delay="5"
             data-ama-enabled="false">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                            <div class="video__endslate">
                                                <button class="video__endslate-close-button" aria-label="close"></button>
                                                <h4 class="video__endslate-heading">More Videos</h4>
                                                <ul class="video__endslate-list">
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <div class="video__animation video__animation_side_top"></div>
                                                                    <div class="video__animation video__animation_side_right"></div>
                                                                    <div class="video__animation video__animation_side_bottom"></div>
                                                                    <div class="video__animation video__animation_side_left"></div>
                                                                    <img class="video__endslate-thumbnail" src="https://media.kare11.com/assets/KARE/images/cfac5721-b746-403f-9275-6dbc5814287c/cfac5721-b746-403f-9275-6dbc5814287c_1920x1080.jpg" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-countdown">Next up in <span class="video__endslate-counter">5</span></p>
                                                            <p class="video__endslate-title video__endslate-title_primary_true">Example video title will go here for this video</p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                </ul>
                                            </div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                        <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "&#x27;Wonder of the Wolves&#x27; offers in-depth look at northern Minnesota pack",
                    "description": "Disney is behind a new series that offers an unusually close look at the evasive beast known as the wolf, and the subjects are from northern Minnesota.",
                    "thumbnailUrl": "https://media.kare11.com/assets/KARE/images/cfac5721-b746-403f-9275-6dbc5814287c/cfac5721-b746-403f-9275-6dbc5814287c_1920x1080.jpg",
                    "uploadDate": "6:49 AM CDT July 13, 2022",
                    "duration": "",
                    "contentUrl": "https://www.kare11.com/video/news/local/kare11-sunrise/wonder-of-the-wolves-offers-in-depth-look-at-northern-minnesota-pack/89-f951b892-f04a-4b0e-973e-03b2449819b9",
                    "embedUrl": "https://media.kare11.com/embeds/video/responsive/89-f951b892-f04a-4b0e-973e-03b2449819b9/iframe"
                    }
                        </script>
                </div>
        </div>
        <p class="related-videos__topic">In Other News</p>
        <h4 class="related-videos__title">&#x27;Wonder of the Wolves&#x27; offers in-depth look at northern Minnesota pack</h4>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
    <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_flex_btf/entertainment/entertainment-tonight"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-position="article_flex_btf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/article_flex_btf/entertainment/entertainment-tonight&amp;sz=970x250|728x90|1140x286|1x1&amp;c=2" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full">
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
    </div>

            </div>
        </main>
            <div class="page__footer page__footer_theme_default">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="KARE-TV" src="/assets/shared-images/logos/kare.png">
            </div>
            <div class="footer__menu">
                    <ul class="footer__list" role="list">
                                <li class="footer__item" role="listitem"><a class="footer__link" href="https://www.kare11.com/karejobs" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                    </ul>
                    <ul class="footer__list" role="list">
                                <li class="footer__item" role="listitem"><a class="footer__link" href="https://interactive.kare11.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item footer__item_visible_false" role="listitem"><a class="footer__link footer__link_behavior_show-consent-options" target="_self" href="/do-not-sell-my-information">Do Not Sell My Personal Information</a></li>
                    </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2022 KARE-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
    <div data-module="ad" class="ad ad_position_exit_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/mn-minneapolis-KARE-B3323_DesktopTablet/exit_interstitial/entertainment/entertainment-tonight"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-position="exit_interstitial"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
        <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="KARE" src="/assets/shared-images/logos/kare.png" />
    </div>
    <h2 class="notifications__heading">KARE would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/assets/shared-images/logos/kare.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
<div class="modal modal_open_false" data-theme="modal">
    <button class="modal__close-button" aria-label="close"></button>
    <div class="modal__content"></div>
</div>    <script src="https://amp.akamaized.net/hosted/1.1/player.esi?apikey=tegna&amp;version=9.1.8"></script>
    <script>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</script>
    <script data-base="/" data-modules="accessibility-statement,ad,adchoices,all-alerts,app-badge,app-promo-link,article,article-loader,article-sharing,article-verify-claim,article-verify-follow-subscribe,breaking-news-alerts,breaking-news-list,carousel,chapter-slider,closings,countdown,election-single-race,elections,error,footer,from-you,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,lazy-image,live-broadcasts,live-video-banner,longform,mini-live-video,modal,nbc-olympics-live-streams,nbc-olympics-medals-count,nbc-olympics-tv-schedule,newsletter-signup,notifications,olympics-medal-count,page,personal-info,photo,pollen,privacy,public-good,radar-gallery,raw-html,related-stories,related-videos,right-now-hourly,right-now-radar,search,story,story-list,story-row,taboola,toasts,tos,universal-ad,video,watch-carousel,watch-live,watch-secondary-content,weather-10-day,weather-alerts-list,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="6.5.4">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset.modules.split(","),s=(e.push("byocarousel"),["page","photo","lazy-image","ad","gallery","video","taboola","related-stories","raw-html","elections","election-single-race"]);for(var a=document.querySelectorAll("[data-module]"),t=0;t<a.length;++t)n=void 0,function(e,s){for(var a=s.length,t=0;t<a;t++)if(s[t]===e)return 1}(n=a[t].getAttribute("data-module"),s)||s.push(n);var r=document.currentScript.dataset.version,i=document.currentScript.dataset.base,l=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.tealiumUrl:"",o=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.hlsJsUrl:"";const m={utils:"tegna-utils_"+r,bem:"bem_"+r,"jquery-utils":"jquery-utils_"+r,storage:"tegna-storage_"+r,common:"common.min_"+r,"live-messages":"assets/js-libs/live-messages/live-messages",luxon:"assets/js-libs/luxon/luxon.min",tealium:l,signalr:"assets/js-libs/signalr/signalr.min",hls:o,comscore:"assets/js-libs/comscore/comscore.min",places:"//maps.googleapis.com/maps/api/js?key=AIzaSyBEGr3U4E-OGcjwkhiXfqxfuvOqDQ7Z96c&libraries=places",pgm:"//assets.publicgood.com/pgm/v1/pgm-api","@firebase/app":"firebase-app","@firebase/messaging":"firebase-messaging"};e.forEach(e=>{e in m==!1&&(m[e]=e+"_"+r)}),require.config({baseUrl:i,waitSeconds:30,bundles:{common:["page","universal-ad","header","footer","grid","breaking-news-alerts","tegna-utils","tegna-storage","tegna-tracking","header-updater","byocarousel"]},paths:m,shim:{signalr:{exports:"signalR"},tealium:["jquery"]}}),s.forEach(s=>{try{require([s])}catch(e){console.warn("Module failed: "+s)}})}var n}();
//# sourceMappingURL=configure-require.js.map</script>
        <script data-api-key="AIzaSyAGdGwCMz-NCR74o5XcMUnhA-s6Fsjp_lc" data-project-id="kare-news-app" data-sender-id="755007164005" data-app-id="1:755007164005:web:a592b8a581f1cb4d">!function(){var e,a,i,p,t;window.tegna.supportsJavascript&&(e=document.currentScript.dataset,a=e.apiKey,i=e.projectId,p=e.senderId,t=e.appid,require(["@firebase/app","@firebase/messaging"],function(e){e.initializeApp({apiKey:a,authDomain:i+".firebaseapp.com",databaseURL:`https://${i}.firebaseio.com`,projectId:i,storageBucket:i+".appspot.com",messagingSenderId:p,appId:t}),window.firebase=e}))}();
//# sourceMappingURL=firebase.js.map</script>
    <script>!function(){function e(){for(var e,t=document.getElementsByTagName("noscript"),n=0;n<t.length;n++){var r=t.item(n);r.outerHTML=(r=r.innerHTML,e=void 0,(e=document.createElement("textarea")).innerHTML=r,0===e.childNodes.length?"":e.childNodes[0].nodeValue)}}var t,n,r;window.tegna.supportsJavascript||(t=document.body,(n=document.createElement("div")).innerHTML='<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>',t.insertBefore(n,t.firstChild),e(),r=window.setInterval(function(){document.getElementsByTagName("noscript").length?e():clearInterval(r)},500))}();
//# sourceMappingURL=old-browser.js.map</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
    <script>window.performance.mark('tegna_dom_parsed');</script>
    <script>window.tegna = window.tegna || {}; window.tegna.loaded = true;</script>
</body>
</html>
